DaVinci Team - SonyEricsson Remote Unlocking and Flashing !

Cable Modification Manual

 Back
Currently modded cables : original DCU-11 cable and cheap china USB cable (dcu-11 copy)
Both cables are based on PL-2303xx USB-to-serial adapter IC

Let's start with cheap china cable ...
ok, let's start...You need one cheap, china USB datacable for SonyEricsson phones, based on PL-2303 IC (ProLific IC)
(other cable types can also be used, but need slightly different modifications)
Disassemble the main interface part, you will see PL-2303 IC. From one side is USB connection, from the other is connection to phone.

In our case five wires were going to phone. we cutted two of them, so the 3 wires left are:

Gnd, Rx and Tx. Thats exactly what we need.
On the pictures you can see
White, Blue and Blackwires.
This is the same interface, just from
the other side...
Cut the unused wires from interface and from the main connector.
On the original cable we got, wires were diffrent connected, so we just resoldered them
to the right place, according to the picture from right, and also applied shorting from pin 9 to pin 11.
Now, connect the cable to USB port and install drivers from the supplied CD.

Go to Control Panel, then System, then Device Manager and under COM ports section,
check the settings for virtual COM port.

In our case, virtual COM port is com5.
Open the logger, under COM port section adjust the virtual COM port that is shown under device manager,
and adjust to maximum speed ...

Congratulations!!!
Now you are ready to Flash and unlock new SonyEricsson phones at maximum speed, 100% safely.
Many people asked how to modify original DCU-11 cable... so we got one and modded it :)
Take the original cable sand start disassembling...

Remove the sticker and the the screws, open the main connector part using your favourite screwdriver :)
After opening, you can notice PL-2303 controller
and also 24c02 eeprom, which holds USB identity
data (when you plug cable, PC see device
as DCU-11 datacable)

NOTE: If you have some spare time, you can also
take out the eeprom, read it on EE programer
and modify data inside, so next time when plugged
in PC, it can be identified as, for example

DC-10 DaVinci USB SonyEricsson CABLE

we had no time for testing this,
but probably can be done, this is just an idea :)
Here starts the modding:

ShortCut pin9 and pin11,
which enables TestMode on phone. take a sharp scalpel
and cut all pins from this side, which leads directly
to PL-2303 IC.

If you dont cut all leads, some errors can be ocured
later, when you start and use the client SW.
Dont forget to cut the contacts
from the other side too.
Now, prepare some isolated wire and connect from
pin7 on main connector to pin5 on PL-2303 IC.
Also connect pin6 on main connector to
pin1 on PL-2303 IC. And ... thats it.

Check again all solderings
and connections, as this is very important
for flashing, because flashing will produce errors
on hisgest speeds if solderings are bad
or too thin wire is used.

Pack the interface back to its plastic cover,
and it's ready to work!
Now, connect the cable to USB port
and install drivers from the supplied CD.

Go to Control Panel, then System, then Device Manager and under COM ports section,
check the settings for virtual COM port.

In our case, virtual COM port is com5.

Open the logger, under COM port section
adjust the virtual COM port that is shown under device manager,
and adjust to maximum speed ...

Congratulations!!!
Now you are ready to Flash and unlock
new SonyEricsson phones at maximum
speed, 100% safely.
Here is the picture of our modded cable...

Some benchmark tests :

K700i flashin took about 7 minutes (in our case),
at maximum baud rate, with CLEAR CALL TIMER option selected,
and just to compare, at 115200bps it would took abot 32 minutes !

You can also increase speed via regular COM port,
using SHSMod drivers. Maximum speed in this case varies
from Motherboard (if supported at all), OS, and of course - cable Quality
and can be up to 460800bps ... in our case, with home-made Max232 interface,
and some really cheap cable, we gained 230400bps speed,
which is much better than 115200bps... so the flashing of K700i
completed in approx 16 minutes.

If you can't get cheap USB china cables, consider the possibility
of increasing COM port speed too.

SHSMod drivers can be downloaded from :: HERE ::

note: If you have some other cable types, like DCU-11 (original SE cable)
but it doesnt work ... you can modify it in similiar way
or ... if you cant make it work ... just drop an e-mail
and we'll make something out :)

© 2oo4 DaVinci Team
© 2oo4 by DaVinci Team. Designed by D a M a s t a