Created using
htm2chm 3.0

Download it NOW!


Как прошить Ericsson SonyEricsson

Работа с программой Sony Ericsson Terminator v1.8

Описание работы:

- Установить для ЛПТ-порта режим ECP+EPP (в настройках BIOS вашего компьютера).
- Подключить донгл одновременно к LPT и USB-портам.
- Подключить кабель к телефону.
- Запустите софт.
Телефон должен быть выключен, а его аккумулятор максимально заряжен. Выберите в программе номер модели вашего телефона и нажмите нужную вам кнопку:
- Read all Codes (прочесть все коды)
- Reset User Code (сбросить код пользователя)
- Remove SP Locks (удалить коды сети)
После этого в программе появится индикация процесса загрузки телефона, до тех пор, пока телефон не будет разблокирован (это может занять до 1мин). Если программа выдает сообщение об ошибке, то попробуйте сделать следующее:
- Во время загрузки нажмите несколько раз кнопку On на телефоне (кратковременно, что бы телефон не включился).
- Нажмите нужную кнопку на программе и сразу-же после этого вставьте кабель в телефон.

Рекомендуется, что бы вы сначала считали все коды программой, а затем ввели их в телефон вручную. Код для входа в Меню Разблокировки телефона такой: <**<

--------------------------------------------------------------------------------

Работа с программой DIV v6.2

Инсталляция:

- Установить для ЛПТ-порта режим ECP+EPP (в настройках BIOS вашего компьютера).
- Подключите донгл в LPT порт.
- Подключите донгл к USB-порту.
- Запустите софт.
Внимание: не запускайте программы с CD, сначала скопируйте их на жесткий диск и снимите флажок "только для чтения" в свойствах файлов программ!

Работа с программой:

- Подключите телефон без аккумулятора к кабелю
- Вставьте аккумулятор в телефон
- НЕ включайте телефон!!
- Запустите программу T100-r600_boot.exe, если ваш телефон 'non original' SonyEricsson (A3618, T100 или R600)
- Или запустите программу all_boot.exe для остальных моделей телефонов.
- Программа напишет, что-то вроде ERROR 0000, так и должно быть.
- Затем, не отключая кабель, запускаете программу DIV 6.2
- Произведите желаемые операции
- Снимите аккумулятор
- Отключите кабель из нижнего разъема телефона!!! Аккумулятор телефона должен быть максимально заряжен !!!
!!! НЕ нажимайте никаких кнопок на телефоне, когда идет процесс загрузки на телефон !!!

Производите операции точно в этой последовательности, особенно для R600 и T100. Для A3618, R600 и T100 не забывайте снять и поставить обратно аккумулятор перед включением телефона, потому, что после считывания Network Codes, телефон остается в TEST MODE. Так же, на этих моделях, после ввода Network Codes (для снятия SP-lock) выключите телефон кнопкой ON/OFF. Lock/unlock статус сохраняется в flash памяти только после выключения телефона!
Для A3618 нужна особая процедура: он должен быть подключен БЕЗ аккумулятора, и ПОСЛЕ нажатия нужной кнопки на программе (например, Read All Codes) вставьте аккумулятор.
Для T300, для предотвращения ошибок, лучше закрывать крышку аккумуляторного отсека во время любых операций, так как на этой модели аккумулятор фиксируется недостаточно прочно без этой крышки, и во время работы программы может пропасть контакт.

Если во время работы произошел сбой, то проделаете следующее:

Снимите аккумулятор
Отсоедините кабель
Подключите кабель
Вставьте аккумулятор
Повторите заново нужную операцию
!!! ОЧЕНЬ ВАЖНО !!!
НИКОГДА не пытайтесь записать Flash file от одной модели телефона на другой!! Особенно если вы запишите Main Flash (AVR) файл от моделей с "большим флэшем" (T68, T300), на модель с "маленьким флэшем" (R520, T39, T65, T200), то вы можете навсегда испортить свой телефон, так как Security Area в области GDFS будет перезаписана!!

Где сохраняются коды сети (Network codes)?
Network Lock/Unlock codes (NCK, NSCK, CCK, and SPCK) так же сохраняются в файле "CODESLOG.TXT". Это очень полезно для телефонов A3618 and R600, так как программа показывает на экране только Network UNLOCK codes. Другие коды (для блокировок в сети) вы можете найти в лог-файле "CODESLOG.TXT", расположенном в текущей рабочей директории.

Как преобразовать T68m в T68i

Записать (upload) GDFS file "T68m_to_T68i_Version2.GDF"
Записать (upload) Main CPU (AVR) с желаемым языком (language) от T68i или T68ic
Записать (upload) Modem flash (ARM) от T68i или T68ic. Всегда используйте файлы с теми же версиями прошивок, что и для Main CPU! Например, если вы записали Main CPU из файла "T68i_EMEA1_R5C001.sbn", то вы должны использовать Modem flash из файла "T68i_Modem_R5C001.arm" (в таком случае версия прошивки для этих двух файлов будет R5C001). Так же, если вы используете для Main CPU файл "T68ic_HongKong_R2A014.sbn", то вы должны использовать из файла "T68ic_Modem_R2A014.arm" (здесь версия прошивки будет R2A014 для обоих файлов).
Отсоедините кабель от телефона.
Нажмите кнопку NO (Power) в течение 4-5 секунд. Не паникуйте, если телефон сразу не включится!
Подождите 10-20 секунд, пока телефон не включится (новая прошивка будет инициализировать телефон, и это займет некоторое время).

Как преобразовать T300 в T310

Записать (upload) Main CPU (AVR) с желаемым языком (language) от T310
Записать (upload) GDFS file "T300_to_T310.GDF"
Отсоединить кабель от телефона.
ВНИМАНИЕ
Когда используете любой файл с прошивками (FLASH file), он должен быть сначала перезаписан из CD на жесткий диск компьютера и флажок "только для чтения" (Read Only) должен быть снят!

Описание некоторых операций в области GDFS
Все новые телефоны Sony-Ericsson имеют специальную область в микросхеме Flash под названием GDFS. Эта область используется потому, что новые телефоны не имеют более отдельной микросхемы EEPROM. Там хранятся все параметры телефона (коды блокировок сети, пользователя, калибровки радиотракта, игры, установки для дисплея и многое другое...). При использовании программы DIV версии 6.2 возможна операция под названием "ЗАПИСЬ GDFS" (Write GDFS) для всех 'original brand' телефонов Sony-Ericsson. Так же в комплекте поставляется дополнительные GDFS файлы для различных операций по апгрейду телефонов. Эти файлы хранятся в специальном текстовом формате и НЕ ПЫТАЙТЕСЬ редактировать их (вы можете испортить ваш телефон навсегда)! Так же, используйте только те файлы, которые предназначены для вашей модели телефона!

Здесь мы приводим описание некоторых GDFS файлов поставляемых на CD:

"T68m_to_T68i_Version2.GDF" - используется для апгрейда телефонов T68m в T68i
"T300_to_T310.GDF" - используется для апгрейда телефонов T300 в T310 (будут добавлены новые игры)
"T39_EMS_fix.GDF" - используется для устранения ошибок в сообщениях EMS для телефонов T39
"T65_Volume00_fix.GDF" - удаляет ошибку "Volume 0/0" после перепрошивки телефона T65
"T68_HBH30_Echo_fix.GDF" - устраняет проблему эха при работе с гарнитурой HBH30
"T68_Reset_Joystik_Counter.GDF" - сбрасывает счетчик джойстика для Т68
"T68_Set_Mic_Normal.GDF" - устанавливает чувствительность микрофона в нормальное состояние для Т68
"T68_Volume00_fix.GDF" - удаляет ошибку "Volume 0/0" после перепрошивки телефона T68
"ALL_Models_Channel_Menu_ON.GDF" - разрешает меню "Channel info" (для всех моделей)
"ALL_Models_Channel_Menu_OFF.GDF" - удаляет меню "Channel info"
В дальнейшем возможно появление новых файлов GDFS для различных операций ремонта/восстановления прошивок телефона.

Некоторые замечания по прошивке и что такое "AVR CPU" и "ARM CPU"
Внутри новых 'original brand' телефонов SonyEricsson находятся 2 процессора (CPU's). Один из них - это основной Main CPU (микросхема AVR), и второй - это Modem CPU (микросхема ARM).
Main CPU (AVR chip) служит для большинства функций телефона, включая языковые пакеты. Modem CPU (ARM chip) служит для инфракрасной связи (IRDA), Bluetooth и для передачи данных и факсов.
В 'non original' телефонах SonyEricsson (таких, как A3618, R600 и T100), находится только один Main CPU (ARM chip). Так же на последних моделях 'original brand', таких как T200 и T300, Modem CPU (ARM chip) так же больше не присутствует.
Когда телефон флэшируется, то обычно достаточно перепрошить только Main CPU (AVR chip). Modem CPU (ARM chip) необходимо перепрошивать только при апгрейде T68m в T68i или при прошивке на более высокую версию (например, от R2A к R5D и т.п.). Так же, если появляется какая нибудь ошибка в меню "Connect" или "WAP services", или телефон выключается при попытке войти в одно из этих меню, то так же необходимо перепрошить Modem CPU (ARM chip). Так же это нужно сделать, если будут ошибки при работе с Bluetooth. Во всех других случаях Modem CPU нет необходимости перезаписывать.

--------------------------------------------------------------------------------

Работа с программой DIV v8.4

Программа DIV 8.4 позволяет:

FLASH:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc, T100, T102,
A3618s, A3618sc, R600s, R600sc

READ CODES:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc, T100, T102,
A3618s, A3618sc, R600s, R600sc

DIRECT UNLOCK:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc

LOCK TO NETWORK (2 and 3 digits MNC):
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc

EMPTY BOARD FLASHING:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc
(also reflash allready flashed empty phones without closing 4 locks)

CHANGE IMEI:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc

MAKE GDFS BACKUP:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc

REPAIR 4 LOCKS CLOSED BY OTHER SOFTWARES:
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc, T65s, T39m, T39mc, R520m, R520mc

REPAIR TOTALY DAMAGED GDFS (4 locks closed):
T610 (all versions), P800, P802, T310, T310c, T300, T302, T200, T202,
T68i, T68ie, T68m, T68mc