T28 Service and Data Cable Conversion

The T28 service and data cables are used by a great number of people to unlock and flash (service cable) and to transfer files and phonebooks (data cable) on [Sony] Ericsson phones. I got my from Face Off Mobiles for about £15, including a Total Server credit.

Below is a proper guide, based on theslugger's work posted at esato.com, to convert a service cable to a data cable, and vice versa. The pictures shows the service cable, use that for general reference.

Note: There are no visual difference between a service and a data cable, the only thing might be the label. If you own a multimeter you can do a conunity check on pin 9 and pin 11 (look below), it should be a closed circuit (i.e. 0 ohms and/or beeping).

The Cable

The cable came in a nice anti-static bag. | 1 meter cable should be sufficient.
Serial port end. | Phone connector end. | The wires used inside the cable are rated as 28 AWG.

To open the phone connector press the two tabs on the back end together and the front tabs apart and it should easily flip open.

You don't really need to open the serial connector since all the conversion is done on the other end. The connector is glued together and is a bit harder to open, use a screwdriver to break it open in the front section.

Phone Connector

Top side | Bottom side | Connector pins, left to right from 1 to 11.

This is where you are going to alter the cable. The data cable and the service cable are utilizing four wires for GND, +5v (for cable circuit), Rx (Receive data) and Tx (Transmit data), three of which needs to be altered. Here's a wiring overview for both cables:

Service Cable
6. Data to Phone (Rx)
7. Data from Phone (Tx)
9. Test&Flash. Connected to pin 11
10. Ground
11. +5v for cable circuit

Data cable
4. Data to Phone (Rx)
5. Data from Phone (Tx)
9. Test&Flash. NOT CONNECTED!
10. Ground
11. +5v for cable circuit

Color scheme:

 | Rx | Tx | +5v and Test&Flash | GND
Data cable | Pin 4 | Pin 5 | Pin 11 single (+5v) | Pin 10
Service cable | Pin 6 | Pin 7 | Pin 9 and 11 | Pin 10

Since the phone interface is using difference Tx and Rx pins for flashing and transferring data, you will need to switch those wires depending on the action you want to do. In addition, if you want to flash or unlock you need to join the +5v pin with the Test&Flash pin.

To put it simple, the wires needed to be switched are as follows:

 | Rx | Tx | +5v and Test&Flash
Service to Data cable | Wire 6 to 4 | Wire 7 to 5 | Wire 11 single
Data to Service cable | Wire 4 to 6 | Wire 5 to 7 | Join wire 11 with pin 9

It's recommended that you use a 15-25 watt solder iron with a small tip, preferably 1-3 mm. If you don't own a solder iron you can also twist the wires around the pins but this is far from safe and you'll probably short some of the wires if you're not careful enough.

Service Cable Wiring

Service cable wiring. The yellow arrows shows the pins used for the conversions. | Another angle.

Data Cable Wiring

Data cable wiring. The yellow arrows shows the pins used for the conversions. | Another angle.

When you're finished make sure when you close the connector that you don't bend any of the wires in an angle. See inside-connector-picture above.

Serial Connector

Nothing needs to be altered on this end, these pictures only serves as wiring reference.

Top side. | Bottom side.
RS 232 circuit. | Maxim MX232CPE chip.
From top to bottom: Orange-Green-White-Blue. | Another angle.

References

Convert a data/service to service/data cable [esato.com]
Data cable for Ericsson R320s [narod.ru]
T27 Pinouts and Schematic Cable [gmshacking.com]

by 2003-2004

T28 Service and Data Cable Conversion

The T28 service and data cables are used by a great number of people to unlock and flash (service cable) and to transfer files and phonebooks (data cable) on [Sony] Ericsson phones. I got my from Face Off Mobiles for about £15, including a Total Server credit.

Below is a proper guide, based on theslugger's work posted at esato.com, to convert a service cable to a data cable, and vice versa. The pictures shows the service cable, use that for general reference.

Note: There are no visual difference between a service and a data cable, the only thing might be the label. If you own a multimeter you can do a conunity check on pin 9 and pin 11 (look below), it should be a closed circuit (i.e. 0 ohms and/or beeping).

The Cable

The cable came in a nice anti-static bag. | 1 meter cable should be sufficient.
Serial port end. | Phone connector end. | The wires used inside the cable are rated as 28 AWG.

To open the phone connector press the two tabs on the back end together and the front tabs apart and it should easily flip open.

You don't really need to open the serial connector since all the conversion is done on the other end. The connector is glued together and is a bit harder to open, use a screwdriver to break it open in the front section.

Phone Connector

Top side | Bottom side | Connector pins, left to right from 1 to 11.

This is where you are going to alter the cable. The data cable and the service cable are utilizing four wires for GND, +5v (for cable circuit), Rx (Receive data) and Tx (Transmit data), three of which needs to be altered. Here's a wiring overview for both cables:

Service Cable
6. Data to Phone (Rx)
7. Data from Phone (Tx)
9. Test&Flash. Connected to pin 11
10. Ground
11. +5v for cable circuit

Data cable
4. Data to Phone (Rx)
5. Data from Phone (Tx)
9. Test&Flash. NOT CONNECTED!
10. Ground
11. +5v for cable circuit

Color scheme:

 | Rx | Tx | +5v and Test&Flash | GND
Data cable | Pin 4 | Pin 5 | Pin 11 single (+5v) | Pin 10
Service cable | Pin 6 | Pin 7 | Pin 9 and 11 | Pin 10

Since the phone interface is using difference Tx and Rx pins for flashing and transferring data, you will need to switch those wires depending on the action you want to do. In addition, if you want to flash or unlock you need to join the +5v pin with the Test&Flash pin.

To put it simple, the wires needed to be switched are as follows:

 | Rx | Tx | +5v and Test&Flash
Service to Data cable | Wire 6 to 4 | Wire 7 to 5 | Wire 11 single
Data to Service cable | Wire 4 to 6 | Wire 5 to 7 | Join wire 11 with pin 9

It's recommended that you use a 15-25 watt solder iron with a small tip, preferably 1-3 mm. If you don't own a solder iron you can also twist the wires around the pins but this is far from safe and you'll probably short some of the wires if you're not careful enough.

Service Cable Wiring

Service cable wiring. The yellow arrows shows the pins used for the conversions. | Another angle.

Data Cable Wiring

Data cable wiring. The yellow arrows shows the pins used for the conversions. | Another angle.

When you're finished make sure when you close the connector that you don't bend any of the wires in an angle. See inside-connector-picture above.

Serial Connector

Nothing needs to be altered on this end, these pictures only serves as wiring reference.

Top side. | Bottom side.
RS 232 circuit. | Maxim MX232CPE chip.
From top to bottom: Orange-Green-White-Blue. | Another angle.

Revisions

  • 2004-10-24 21:00: Initial release

References

Convert a data/service to service/data cable [esato.com]
Data cable for Ericsson R320s [narod.ru]
T27 Pinouts and Schematic Cable [gmshacking.com]

by 2003